pecl install mongo - not a valid package archive

On June 23rd 2014 @ 9:30am GMT, while trying to ‘vagrant up’ a development environment at work, I was getting messages of failed dependencies when installing mongo.

A quick SSH onto the box and the following output was revealed.

sudo pecl install mongo
downloading mongo-1.5.4.tgz ...
Starting to download mongo-1.5.4.tgz (Unknown size)
....done: 3,582 bytes
Could not get contents of package "/build/buildd/php5-5.3.10/pear-build-download/mongo-1.5.4.tgz". Invalid tgz file.
Download of "pecl/mongo" succeeded, but it is not a valid package archive
Error: cannot download "pecl/mongo"
Download failed
install failed

Further googling revealed similar issues, others suggested the problem with certain 32bit versions of PHP. This made no sense either as it had been working before the weekend.

The actual problem? The pecl site was active, but the DB down sigh:

PECL Database Connection Error

This apparently isn’t the first time this has happened and as a single point of failure is slghtly worrying.

*** Update - June 23rd 2014 @ 11:24am *** The pecl is now back up

Ben Squire

Read more posts by this author.

Leicestershire, United Kingdom https://squired.co.uk